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Getting started 

Installing Business Process Visual ARCHITECT (BP-VA)  

After you have downloaded Business Process Visual ARCHITECT (BP-VA) from our website, the next step you 

should do is to install it. The following steps are going to teach you how to install it: 

1. Double click the downloaded installer file to execute it, then click Next button to go to next page. 

  

2. Go through the License Agreement. Choose I accept the agreement after you finish reading the 

agreement and fully understand and accept the terms, and then click Next. 

3. Select the destination you want BP-VA to be installed, and then click Next. 

4. Select the location you want the Start Menu folder to be placed, which is the location where the program’s 

shortcut is, under the Start menu. Click Next. 

5. Select the file associations that you want to create. Click Next. 

6. Fill out the Products Configuration. Select the edition you have purchased or you want to evaluate, then 

click Next.  

 

7. The installation has been completed. You can choose either to start it now by clicking Business Process 

Visual ARCHITECT and then click Finish or start it later on by clicking Don’t start. 
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Starting BP-VA 

You can start BP-VA by selecting Start Menu > Visual Paradigm > BP-VA Animacian Edition. 

Importing license key 

1. After you enter BP-VA, you will be asked to provide license key in License Key Manager.  

 

a) If you have purchased BP-VA, you should have the permanent license key. Click Import key to 

import your permanent license key in Key Manager.  

 

b) For evaluation, please click either Try without key or Request key. Choosing Try without key 

provides 10 days evaluation period without input your email while choosing Request key lets you 

request for an evaluation key that allows you to evaluate 30 days. If you are our member, you will be 

asked to sign in after you click Request key. If you are not our member, you should register as a 

member on Internet by filling the Registration form. The key will be sent to your email account 

automatically after you have signed in.  
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Selecting workspace 

Workspace is a directory that can memorize your own setting and preferences.  You will be asked to select a 

workspace every time you start BP-VA. If you would like to keep the application settings, always start with the 

same workspace. When you move to a new computer, you just need to copy the workspace, and then all settings will 

be kept. If you want to have a fresh working environment, start with a new workspace. 

 

Environment 
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Menu bar, Toolbar, Diagram Navigator, Property pane, Message Pane and Diagram Pane are shown on the 

environment of BP-VA window. The brief introduction of each function shows in the following table: 

1 Menu bar The menu bar at the top of the window allows you to select and perform various 

operations in BP-VA. 

2 Toolbar Toolbar, which is below the menu bar, is the extension of menu. All buttons are 

presented as groups of icons that handily placed for users. 

3 Diagram 

Navigator 

A place where diagrams are listed, and where you can create and access diagrams base 

on their types. 

4 Properties Pane The properties of chosen model/ shapes will be shown on properties pane upon 

selection. 

5 Message Pane Possible information or warnings will be shown here. 

6 Diagram Pane The diagram will be displayed in diagram pane. 

Saving and opening projects 

To save your work, select either File > Save Project or File Save Project as…. When you perform saving the 

first time, you can select to save the project in workspace, or to another directory you preferred. 

 

To open an existing project, select File > Open Project… from the main menu and select the project to open. 
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Diagramming 

After you are familiar with the environment of BP-VA, you should get to know how to create a diagram. This 

chapter is going to teach you not only how to create diagrams, but also how to create and connect diagram elements 

(shapes), documents their details, how to format them and a general description on the nickname and layers feature. 

Creating diagram  

To create a diagram, say a business process diagram: 

1. Right click Business Process Diagram in Diagram Navigator and select New Business Process 

Diagram. 

 

2. Enter the name for the new diagram as Sales order system after creating it. 

 

Creating shapes 

To create a shape, select the type of shape from the diagram toolbar, click on diagram and start dragging it to create 

with a preferred size. Taking creating a task as an example: 

1. Select Task from the diagram toolbar, press on the diagram and then start dragging. Release the mouse to 

confirm creation. 
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2. Enter the name for the task as get an order and press Enter to confirm the name.  

 

Connecting shapes  

Two shapes can be connected by making use of the resource icons surrounding a shape. Let say if we want to 

associate a task with another task, move the mouse pointer towards the task, press on its Sequence/Message Flow -

> Task resource icon and drag it to another task, finally release the mouse button. 

    

Documenting model element 

You can type in the textual description to your shape by opening the Documentation Pane at the bottom left of 

screen and typing in the space provided.  

 

In addition to text description, you can describe by voice through recording. Click the Record button at the bottom 

of Documentation Pane. In the Record Voice dialog box, start recording by clicking the red circle button and stop 

recording by clicking Stop button. To save your recording, click OK. 

 

Note Make sure your recording device is available in order to apply this feature. 
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Formatting shapes 

You can format a shape with your preference by right clicking on it, selecting Styles and Formatting and then 

Formats… from the popup menu. Taking changing the task’s background color as an example: 

1. Right clicking on the task and select Styles and Formatting and then Formats… from the popup menu. 

      

2. In the Formats dialog box, select a color such as pink in the Background tab and click OK to confirm the 

change, the color of task will be changed into pink.  
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Formatting the connector style as another example: 

1. Right click a connector and select Styles and Formatting and then Formats… from the popup menu. 

2. In the Formats dialog box, select gray as line color and click OK to confirm. As a side note, the option 

Weight is used to alter the thickness of the connector. The higher the value in Weight, the thicker the 

connector will become. 

 
 

Using nickname  

Nickname is a feature which helps you to set up and manage multiple language sets of a model. The original 

nickname is defaulted as English. You can add a new nickname for example, Chinese: 

1. Click on the dropdown menu Original on toolbar and choose Configure Nickname…. 

 

2. In the Configure Nickname dialog box, click Add User Language and select Chinese (Traditional) in 

the Add User Language dialog box and then click OK. Finally, click OK to go back to the diagram and 

start working with the Chinese version of model.  

     

Note This feature is only available for Analyst Edition or above. 

 

Note To change the nickname back to English, choose the option Original in the dropdown menu of 

nickname. 
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Layer 

Layer is a feature that lets you divide shapes on a diagram into logical groups, and perform various actions including 

changing their visibility, and disabling the editing on them.  

You can create a new layer by selecting View > Layers… from the main menu. In the Diagram Layers dialog box, 

click on the Create new layer button. Name the new layer as Annotation Layer and then click Close to confirm the 

change. 

 

A shape can be moved to another layer by right clicking on it and selecting the layer to be moved to. For example, a 

callout can be moved from the current layer to a new layer specialized for annotation by right clicking on the callout 

shape and selecting Annotation Layer.  

 

Visibility and accessibility of a layer, or we say the shapes on a layer, can be controlled by opening the Diagram 

Layers dialog box, and checking/un-checking the Visible or Locked columns of the corresponding layer. Note that 

a locked layer will result in making shapes on that layer not selectable or movable. 
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Split diagram view 

BP-VA can split diagram vertically or horizontally for viewing different parts of a huge and complicated diagram 

effectively instead of scrolling back and forth.  

 

Demonstrating the steps of splitting diagram view as follows: 

1. Press the left bottom corner of the diagram and drag it to split the view into two.  

 

2. Release the mouse to confirm the size of views. 
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Business process modeling 

Drawing business process diagram 

A business process diagram is mainly formed by activities like tasks and sub-processes. Each of them represents 

work that an organization performs in a process. The following business process diagram illustrates how to place an 

order in a restaurant: 

1. Select Start Event from the diagram toolbar and click it on the diagram pane. 

 

2. Press on the resource icon Sequence Flow -> Task of start event and drag it into the location you prefer to 

create a task flow from the start event. Name the task as Read Menu. 

 
3. Press on the resource icon Sequence/Message Flow -> Gateway of task and drag it to the preferred place 

to create a gateway. Name the gateway as Leave?. 

4. Press on the resource icon Sequence/Message Flow -> Sub-process of gateway to create a sub-process. 

Name the sub-process as Order Meal. Double click the line linking to Order Meal and name it as No. Press 

on the resource icon Sequence/Message Flow -> Task of gateway to create another task and name it as 

Leave. Double click the line linking to Leave and name it as Yes. 

5. To create an end event, just press the generic resource and drag it to the desired place. Select End Event> 

End Event on the pop-up menu.  

 
6. The sub-process of Order Meal can be specified by clicking the plus button in Order Meal. 

 
7. A new business process diagram will then pop out. You can model the detail of sub-process in this diagram. 

When you want to return to the previous diagram, click Order Meal at the top left corner after you have 

finished editing the sub-process of Order Meal. 

 
8. The symbol on Order Meal will eventually become minus instead of plus as the figure shown below: 

 



Business Process Visual ARCHITECT Quick Start 

Page 14 of 35 
 

Writing operation procedure 

The necessary procedure for a task can be specified by filling in the operation procedure. Taking the example of 

Lookup parcel to illustrate the procedure for looking up parcel: 

1. Create a task lookup parcel and click on it to make the procedure editor revealed at the bottom of diagram. 

If it is not revealed, right click on the background of diagram and select Show Procedure Editor in the 

pop-up menu. 

 

2. Enter Get the tracking number from the parcel owner as the first step in the first row. Press Enter to move 

to the next step. Enter Lookup the parcel with the tracking number and Bring the parcel to the counter as 

the second step and the third step respectively. 

 

Animating business process 

Animacian helps you to make a process design active by presenting the flow in animating form. This can also make 

your design more attractive and can help demonstrating your work to clients accurately. 

1. Draw a business process diagram like this: 
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2. Select Tools> Animacian… from the main menu or press the Animacian button on the toolbar directly to 

launch an animation. 

 

3. Select the path to be executed in the pop-up Business Process Diagram Animacian dialog box and then 

click Play.  

 

Simulating business process 

Simulacian is a set of tools that help you record and study the resource consumption in a business process, monitor 

the duration of activities, find bottlenecks and improve a process. 

1. Draw the following business process diagram X-Ray Inspection: 
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2. Right click on the diagram background and select Diagram Type > Simulacian from the popup menu. 

3. In the Simulacian Control Panel, click Add under Available resource to add a resource X-Ray Machine, 

with Machine as type and 1 as amount. 

 

4. Select the task Register in diagram. In the Simulacian Control Panel, enter 2 m as duration. 

 

5. Repeat the previous step to set Perform Inspection's duration to be 15 m. 

6. Select the pool Patient. In the Simulacian Control Panel, enter 1 as instance. Similar set Doctor's instance 

as 1. 

7. Click on Show Inputs in Simulacian Control Panel. 

8. Under Inputs, click Add to add an input with name Peak hour, with 5 as instances. 

 

9. In the Simulacian Control Panel, set the scale to 10 Mins scale. 
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10. Click Simulate. 

 

11. Study the simulation outcome. The green running circle represents an executing task, while the red inverted 

triangle stands for pending jobs, with the number indicating the number of jobs pended. 

 
You can see that the bottleneck of this process occurs in the task Perform Inspection. In order to improve 

this process, you can employ more doctors by increasing the instance of pool Doctor, and buy more X-Ray 

Machine by increasing the amount of resource X-Ray Machine. 

Constructing as-is and to-be processes 

The current business process can be modeled, and then be transcribed into a to-be adopted process by making use of 

model transitor. Furthermore, the changes that have been made can be traced with visual diff. 

1. To construct an as-is process, right click the project root node Inspection Procedure in Model Explorer 

and select Model> As- is Process. 

 

2. To create a new business process diagram based on as-is process, right click As-is-Process and select 

Diagram> Business Process Modeling> Business Process Diagram. 

 

3. Name the diagram as Inspection procedure As-is Process and develop a inspection procedure diagram: 
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4. Right click on the diagram and select Utilities> Transit to New Diagram… to transit it into to-be process. 
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5. Click New Model in Select Parent Model of New Diagram dialog box and type the name as To-be 

Process in the pop- up Model Specification dialog box. Finally, click OK in both dialog boxes to confirm. 

 

 

6. In the to-be process diagram, rename the task of Issue warning letter to Send inspection report. Make use 

of resource centric interface to jump back to as-is process to review the change.  
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7. The visual diff tool helps you to review the changes between models. Select Tools> Visual Diff… from the 

main menu to start visual diff. 

8. Select Transitor in Strategy and Model Element in Compare respectively in the pop-up Visual Diff dialog 

box. Check Use Working Project and select To-be-process in Diagram on the left dropdown menu. The 

modified model element has been revealed at the bottom of the dialog box. 
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General business modeling 

Working with glossary 

Glossary is a useful tool to help you manage domain-specific terminologies, and clarify them by defining aliases and 

entering documentation. 

1. To start the glossary, select Tools> Model Elements Grid> Open Glossary Grid from the main menu. 

 

2. To create a term, click the Create Term (Insert) button at the top of Glossary Grid. Right click the newly 

created term and select Open Discussion Specification… to open the Term Specification. 

  

3. Click Add to insert an alias for the term. A brief description of the term can be typed in Documentation. 
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Data modeling (ERD) 

Entity relationship diagram (ERD) can be used to demonstrate the conceptual, logical and physical data structure of 

a database. Let see how to develop a conceptual model. 

1. Right click Entity Relationship Diagram from the Diagram Navigator and select New Diagram to 

create an Entity Relationship Diagram (ERD). Select Conceptual Model which is on the top right corner of 

the diagram pane when the new ERD is opened. 

 

2. Select Entity on the diagram toolbar and drag it to the diagram.  Name it as User. A primary key can be 

created by right clicking the entity and select New column and filling in the name by putting a plus sign in 

front of the new column’s name, such as +id. Press Enter to confirm. The primary key is subsequently 

shown as the figure below.  

 

3. Insert a new column without a primary key, just type the name as name in the newly created column. 

 

4. Create another entity by pressing the resource icon One-to-Many Relationship -> Entity and name it as 

Account. Two entities should be linked simultaneously.  

 

Drawing process map 

Process Map Diagram is supported as one of the business process modeling diagrams in BP-VA. It helps to draw a 

simple picture of processes in approaching a business goal and further helps to analyze the business process.  

Taking Submit Assignment Online as an example: 

1. A new process map diagram can be created by right clicking Process Map Diagram on Diagram 

Navigator and then selecting New Process Map Diagram from the pop-up menu. Enter the name for the 

new diagram when it is created.  
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2. Press on Receive from the diagram toolbar and drag it on the diagram. Name the newly created receive 

element as Receive Pin. Move the mouse pointer on the receive element and press the resource icon 

Process Link -> Process to create a process. 

  

3. Name the newly created process as login assignment system. Repeat the previous step to create another 

process upload completed assignment. 

 

4. To terminate the process, move the mouse pointer on the process itself and press resource icon Process 

Link -> Send. Name the newly created send as Send assignment to the tutor. 

 

Drawing data flow diagram 

There are three main elements in a data flow diagram: process, data store and external entity. A process manipulates 

the input data while a data store indicates the location where data is stored. An external entity does either provide 

data/ information to the system or receive data/ information from it. In short, a data flow represents the data/ 

information flowing to or from a process. 

A new data flow diagram can created by right clicking Data Flow Diagram on Diagram Navigator and then 

selecting New Data Flow Diagram from the pop-up menu. Enter the name for newly created diagram. 
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Taking Consignment as an example: 

1. Press on Process from the diagram toolbar and drag it on the diagram pane. Name the newly created 

process as ship goods. 

 

2. To create a data store, move mouse pointer on the ship goods process and press resource icon Data Flow -> 

Data Store. Name the newly created data store as inventory. Move mouse pointer on the ship goods 

process again and press resource icon Data Flow -> External Entity to create an external entity. Finally, 

name it as customer. 

  

Drawing organization chart 

Organization chart shows the structure of an organization. It is usually drawn and read from the top to the bottom.  

Select Organization Chart> New Organization Chart from the Diagram Navigator. A new unit will reveal 

automatically. Enter the name for new diagram and name the newly created unit. 

  

The structure of ABC Company is used as an example in the following steps. The top node is the Executive Director 

as the first level management, the second level managements includes Sales Manager and Marketing Manager and 

the third one is Salesperson and Marketing staff. The lines in organization chart show the relationships between 

staffs.  

1. Name the newly created unit as Executive Director. Move mouse pointer on the Executive Director unit 

and press its resource icon New Subordinate.  
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2. Name the newly created subordinate as Sales Manager. To create a new coworker of Sales Manager, move 

mouse pointer on Sales Manager unit and press its resource icon New Coworker. Name the new created 

coworker as Marketing Manager. 

 

3. Finally, create a subordinate for both Sales Manager and Marketing Manager as Salesperson and 

Marketing staff respectively. 

 



Business Process Visual ARCHITECT Quick Start 

Page 26 of 35 
 

Report Generation 

Generating report 

You can generate a report in form of HTML, PDF or Word from your project by clicking Tools and selecting 

Generate HTML/PDF/Word Report…. For example, select Generate PDF Report… if you would like to 

generate a PDF report. 

 

When the Generate PDF dialog box pops out, select the diagram(s) to be included in report. Fill in Output Path 

and click Generate to proceed with generation. 

 

Customizing report template 

You may customize the output by designing your own template instead of generating report with the built-in 

template. 

1. In the Generate PDF/ HTML/ Word dialog box, select New in the Template drop down menu. 

 

 

2. Report Template dialog box will subsequently pop out, type the name for your report template and start 

the editing. For example, click Add Diagram Loop below the name to create a loop of specific type(s) of 

diagram. 
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3. A tree will be revealed on the right hand side of the Report Template, select Business Process Diagram 

and click the green right arrow to insert it into the loop. 

 

4. Click Add Diagram Image icon on the left hand side of the Report Template, click the Add Element 

Summary on Diagram Loop (Business Process Diagram) icon to insert the summary table of the 

diagram. 

 

5. Select the elements which you prefer to be included from the right hand side and press the right arrow to 

insert it to the included element list.  

6. Click the Add Property Column button from Element Summary to insert a property. Select 

Documentation from the right hand side and Documentation ${value} will automatically reveal on the 

left hand side. Click the Add Property Column Below icon on Documentation ${value}.  

 

7. Select other desired elements on the right hand side respectively following the steps mentioned above. 

8. After you have finished defining the template, click the Save button. You can then return to the Report 

Generation dialog box and select the template to generate report. 
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Publishing report to website 

1. You can publish your report to the website by selecting Tools > Project Publisher… from the main menu. 

 

2. Enter the output path in the Project Publisher dialog box and click OK to publish. 

3. It publishes the project and opens the published content in web browser. You should see three tabs: 

Diagram Navigator, Model Explorer and Logical View on the left and your diagram on the right. Click the 

diagram on the left, it will be shown on the right screen.  

 



Business Process Visual ARCHITECT Quick Start 

Page 29 of 35 
 

4. You can click on a shape, for example a task, on an image to enter its detail page, for reading its properties. 
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Teamwork collaboration 

Your team can work together on the same project effectively through the teamwork collaboration feature. BP-VA 

supports the integration with version control systems such as SVN, CVS, Perforce and Teamwork Server. In this 

section, we will cover basic setup of Teamwork Server, where SVN, CVS and Perforce users can skip, and basic 

teamwork operations with Teamwork Server. The techniques to be taught can be applied to the integration with 

SVN, CVS and Perforce, too. 

Note Teamwork Server is only available for Modeler Edition or above. 

SVN, CVS and Perforce integration are only available for Analyst Edition or above. 

Installing and administrating teamwork server  

1. Download Teamwork Server at: 

http://www.visual-paradigm.com/download/vpts.jsp 

2. Check your Email account for the evaluation key of Teamwork Server. Save the key to your computer. 

3. Execute the Teamwork Server installer. 

 

4. Click Next in welcome page. 

5. In the License Agreement page, read through the agreement, select I accept the agreement if you agree 

with the terms. Click Next to proceed. 

6. Select a destination to install Teamwork Server. Click Next to proceed. 

7. Enter the name of Start Menu folder and click Next to proceed. 

8. In the Windows Services page, select whether or not to install Teamwork Server as service and click Next 

to proceed. 

9. In the Installation Type page, keep the option Server and Admin selected and click Next to proceed. 

10. In the Server Configuration page, scroll down to the part of License. Import the key you saved in step 2. 

Click Next to starting copying files. 

11. Instead of finishing here, we also need to perform administration tasks like to create users and projects. 

Click Start Server in the final page, and click Start Admin with browser. 

12. You should see the admin page being opened in web browser. Enter Admin for both name and password 

and click Login to login. 

 

13. Click on Add User. 

http://www.visual-paradigm.com/download/vpts.jsp
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14. In the Add User page, enter peter as name and password, click Add User. 

 

15. Click Add User again, enter john as name and password. Click Add User. 

16. Open the Projects tab. 

17. Click Add Project. 

18. In the Add Project page, enter My Project as project name. At the Project Users section at the bottom of 

page, select john and peter, and click Add as Read and Update. 

 

19. Click Add Project. 

Login to server  

You can start working by logging into the Teamwork Client in BP-VA, manage, checkout and open the project. 

Manage project is to tell the client products that you are involved in a particular project. 

1. In BP-VA, select Tools > Teamwork > Open Teamwork Client... from the main menu. 
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2. In the Login dialog box, enter 127.0.0.1 as server host, john as name and password (follow that defined in 

the last section). Click OK. 

 

3. In the Manage Project dialog box, select My Project and click > to manage it. Click OK to proceed. 
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Checkout and open project 

Checkout project is to download a managed project from server to your computer. Open project is to open the 

downloaded project in BP-VA. 

1. In the Teamwork Client dialog box, click Checkout at the bottom right corner of dialog box. 

 

2. Click Open Project. 
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Commit 

Commit refers to the process of uploading local modifications to server. 

Create a simple business process diagram as shown below: 

 

1. Select Tools > Teamwork > Commit... from the main menu to commit your changes to server. 

2. The Commit dialog box displays the changes to be committed to server. Click Next to proceed. 
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Update 

Update refers to the process of getting or downloading changes others have committed to server. 

1. Ask another team member to start BP-VA in his/her computer. 

2. Follow the steps as listed in the Login to server section to login to server as user peter. 

3. Checkout and open project My Project. 

4. Open the business process diagram, and rename the task. 

 

5. Follow the steps as described in the Commit section to commit the change to server. 

6. Now, go back to john's environment.  

7. The Update dialog box displays the changes to be updated from server. Select Diagram > Business 

Process Diagram1: BusinessProcessDiagram > Place Order : BPTask. Click Preview. This is to foresee 

the changes before actually updating it. In case the change is not desired, you may click Cancel to abort the 

process. Click OK. 

 

8. Check the task. Its name has been changed to Place Order. 
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